Using Adobe Contribute 4 6E‘TL’

A guide for new website authors conter for gxcellence in feaching and farning

Adobe Contribute allows you to easily update websites without any knowledge of HTML. This handout
will provide an introduction to Adobe Contribute by providing instructions to the following common
tasks:

Recognizing the toolbar and menu controls.

Creating and editing text.

Creating and editing tables.

Inserting and editing images.

Creating and editing hyperlinks.
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Detailed Instructions

Recognizing the toolbar and menu controls.

If you successfully created a connection to your website, then Contribute will automatically
connect to it every time you open the program. The Adobe Contribute window is divided into several
sections (Fig. 1):

1. The Browser panel is used for browsing and editing. The Contribute browser can browse to the
page you want to edit and the toolbar provides access to the most common editing tools.

2. The Pages panel gives you access to the web browser and all drafts you’re currently editing.

3. The How Do ... panel provides quick step-by-step instructions to help you complete some
common Contribute tasks.
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The Contribute toolbar changes according to whether you are browsing or editing a web page. The
browser toolbar contains buttons for navigating your website or creating a page or blog entry.

The browser toolbar contains several buttons (Fig. 2):

[m Edit Page D Mew .., l | (}i Back Forward @ Skop @ Refresh %v Home Pages [
Fig. 2
1. The Edit Page button creates a local draft of the currently displayed webpage and switches the
toolbar to editor mode.
2. The New... button opens the new Web Page dialog box where you may create a new blank web
page or a new page from a template.
3. Standard browsing tools include the Back, Forward, Stop, and Refresh buttons that work exactly
like the browser buttons from Internet Explorer or other web browsers.
4. The Home Pages button allows you to view all of the Contribute home pages you have
configured on that computer.
5. The Contribute button returns you to the Contribute Start Page with access to common tasks
and tutorials.

When you are editing, the editor toolbar lets you edit text or images, depending on the content you’ve
selected. The editor toolbar contains buttons for common operations from the File, Insert, Format, and
Table menus (Fig. 3).

Action buttons Insert content Add rovlu or column
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Fig. 3 o
Page properties
1. The action buttons save your edits and switches the toolbar back into browser mode.
a. Publish saves and uploads your changes to the internet.
b. Send for Review saves your changes and sends a copy to someone for review.
c. Save for Later saves your changes, but does not send them to the internet.
d. Cancel simply discards all of your changes.
2. The Content buttons add different types of content to your page: hyperlinks, images, and tables.
3. The Page properties button opens a dialog box where you may customize the default font,
backgrounds, colors, and other styles on the page.

o Creating and editing text.

Entering or editing content into your page works much like a word processor. Just click a location on the
page to place your cursor and begin typing. The text formatting toolbar contains buttons for formatting

text (Fig. 4). Align left
Center
Style menu Alignright Text color
’ Font menu Font size menu Justify Highlight color
|
Marmal v gDefaJtFont V} 12 Iv EEEE | ISiEEE | A Z
Fig. 4
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Creating and editing tables.

Tables can be used to organize data or arrange other content on your web pages. You can
insert a table anywhere on a page. Remember: You must click Edit Page in order to edit or create
content on your page.

To insert a table:
1. Place the insertion point in your draft where  Tablesize

you want the table to appear. Mumber of raws: E
2. Do one of the following to open the Insert Wi & ealure: B
Table dialog box (Fig. 5): Optiors
e Click the Table button in the toolbar. T Y
* SelectInsert > Table. " Spesific width: 300 [oiee =]

e Select Table > Insert > Table.

3. Complete the dialog box. otz U B3
e Under Table size enter the desired Cel pading pixels between bordsr and conlent
number of rows or columns. L] speeiig pistels et el
e Under Options set a specific width of bleadel
the table as either a fixed number of === - T T
pixels or as a percentage of the viewer’s == = —‘ . —I E —I
Mione Left Top Bath

screen width, the size of the border
(enter 0 if you do not want a border), the padding between the border and cell
contents, and the spacing between individual cells.
¢ Under Header select where headers will be listed in a data table.
4. Click OK.

Fig. 5

To resize a table:
1. Inyour draft, select the table you want to resize.
2. Do one of the following:
¢ To resize the table horizontally, drag the selection handle on the right.
¢ To resize the table vertically, drag the selection handle on the bottom.
¢ To resize in both dimensions, drag the selection handle at the lower right corner.
To resize a column or row:
o Select the column or row, and then drag the right border of the column or the lower border of
the row.

To add rows or columns to a table:
1. Inyour draft, place the insertion point in a table cell. Insert: % Paws
2. Do one of the following: W Tl
e Select Table > Insert > Multiple Rows or Columns.
¢ Right-click, and select Insert Multiple Rows or Columns.

Mumber of rows: | 1

3. Complete the Insert Rows or Columns dialog box (Fig. 6): where: {~ Before current row
e Under Insert choose either Rows or Columns to insert. O S e
¢ Under Number of rows/columns type a number. Fig. 6

e Under Where select either Before current row/column or After current row/column.
4. Click OK.

To delete rows or columns from a table in your draft, do one of the following:
e Select entire rows or columns, and then press Delete or Backspace on your keyboard.
e Select entire rows or columns, right-click, and then select Delete Row or Delete Column.
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You can modify the alignment, width, border width and color, and background color of a selected table.
To modify table properties:
1. Inyour draft, select the table you want to modify.
2. Do one of the following to open the Table Properties dialog box:
e Click the Table button in the toolbar.
e Right-click, and then select Table Properties from the pop-up menu.
e Select Table > Table Properties.
3. The Table Properties dialog box appears (Fig. 7):
¢ Table alignment refers to the location of the table in relation to other elements on that
page:
Default aligns the table to the left side of the page. Text does not flow around the table.
Left aligns the table to the left side of the page. Text flows to the right of the table.
Center aligns the table in the center of the page.
Right aligns the table to the Telle 2iarm - =
right side of the page. Text =
flows to the left of the table. Table width: [302 | Pisels ] B=
e Use Table width to set a specific
width of the table as either a

I'I—
fixed number of pixels or as a Cell padding: I pixelz between border and content

YV VY

Border thicknesz: pixels

percentage of the viewer’s
screen width.

e Use Border thickness to set the
size of the border (enter 0 if you Border color: E Background color: E
do not want a border). Fig. 7

¢ Use Cell padding to set the distance in pixels between the border and cell contents.

e Use Cell spacing to set the distance in pixels between individual cells.

e Use Border color to set the color of the border around the table and between cells.

¢ Use Background color to set the background color of all the cells in the table. If you do not
select a color, the default background is transparent. In other words, the table background
is white on a white page, green on a green page, and so on.

4. Click Apply to apply changes without closing the dialog box, or click OK to apply changes and
close the dialog box.

Cell zpacing: pixels between cellz

You can apply a preset design to a table and select options to further customize the design.
To use a preset table design:

1. Select a table to modify or place Format: S ample:
the insertion point in any cell in the . _
table Simple - Jim Sue Pat Total
able. Simple2 Jan 4 4 3 11
2. From the Table menu select Sirnple3 Feh 2 2 PR
bl Simpled E!
Format Table.
. AltR oz Bluetsellow Mar 4 1 5 10
3. Onthe Format Table dialog box AR ows:E arth Colars Ao B3 1 5
(Fig. 8) select a table design from AltFaws:E arth Colars? Total 15 10 13 38
the Format list box. AltRows:Green&v'ellow
) AltRowsz: B asic Grey
4. Click OK. AR ows:Orange ;I

Fig. 8
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Inserting and editing images.
You can add images from several sources, including your computer, local network, website, e-

mail, web browser, or another application, such as Microsoft Word or Excel. You may copy and paste
images from other applications just as you would in Microsoft Word or Excel or you can use the Image
button on the editor toolbar. Remember: You must click Edit Page in order to edit or create content on
your page.

To add an image using the Insert menu or Image button:

1.
2.
3.

Place the insertion point in your draft where you want the image to appear.

Click the Image button in the toolbar.

Select one of the following options from the pop-up menu:

¢ Choose From My Computer if you are adding a new image to your site.

¢ Choose From Website if you have already inserted an image in a Contribute web page on
this site, and you want to reuse the image.

From the Select Image or Choose Image on Website dialog box that appears, browse and select

the image.

Click the Select or OK button.

The image editing toolbar automatically appears whenever you have an

image selected on your page. It contains buttons for editing images Alignleft
(Fig. 9). When you use Contribute to edit an image in an external Center
application, you edit the Align right
original image source file, so  Resize Resize Justify
these edits affect all instances | | Fig. 9
of that image on your FOC K A© | width: [700 |Height: [72 | ==s=|%
website. ) :
Brightness/Contrast Image properties
The Image properties affect the way Shamea
the image appears on the page. s

To change image properties:

1.

In your draft, do one of the otate

following:

e Double-click the image.

e Select the image, and then click the Image Properties button 5 in the image editing
toolbar.

e Select the image, and then on the Format menu select Image Properties.

¢ Right-click and then select Image Properties.

Make changes as necessary to the Image Properties dialog box (Fig. 10):

¢ Image file is the name and location of the image source file.

¢ Display width is how wide the display area is for the image. This option compresses or
stretches the appearance of the image on this page. You can enter display size in pixels or as
a percentage of the original image size. This option does not affect the original image source
file; it affects only the display of the image on this page.

Page 5 of 7



Fig. 10 Image file: Iute 4/5ites/Sitel AssetsTempffaculty _photo.gif | Browse.., - |

Display width: I 126 IPiers j Reset Display Size |

Display height: I 183 IPiers j ¥ Constrain proportions

Horizonkal padding: I pixels Alignrnent; ILeFt j E=
Wertical padding: I pixels Border: IEI pixels

Descripkion (ALT bexk):

I Home Page Image

This description is used by tools that read web pages ko people with visual disabilities.

¢ Display height is how tall the display area is for the image. This option compresses or
stretches the appearance of the image on this page. You can enter display size in pixels or as
a percentage of the original image size. This option does not affect the original image source
file; it affects only the display of the image on this page.

¢ Reset Display Size returns the image to its original height and width. This option acts like an
undo button for changes to image size.

¢ Constrain proportions keeps the proportions of height and width constant so that the image
is not distorted. For example, if you double the height with this option enabled, Contribute
also doubles the width.

e Horizontal/Vertical padding is the amount of empty space, in pixels, around the image. The
number you enter represents the amount of space on each side of the image.

¢ Alignment refers to the location of the image on the page in relation to any text that
appears around the image. When you select an alignment option, a graphic indicates how
the image will align in relation to elements around the image.

e Border is the width, in pixels, of the border around the image.

e Description (ALT text) describes the image for users with disabilities or for users whose
browsers set to display only text.

2. Click OK when done.

o Creating and editing hyperlinks.
With Adobe® Contribute 4, you can make text or images in your web page act as links. Your
text or image can link to any of the following:
e A current draft or a recently published page on your website.
¢ A new web page, which Contribute creates at the same time as the link.
¢ An existing web page on your website or on another website.
¢ Ane-mail address.
¢ An existing file on your computer, such as a Microsoft Word or PDF file.
Remember: You must click Edit Page in order to edit or create content on your page.

To create a link to a page on your website or on another website:
1. Select the desired text or image.
2. Click the Link button on the editing toolbar and select Browse to Web Page.
3. The Insert link dialog box appears (Fig. 11)
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Fig. 11
= 3 - o e Preview: | Refresh l
=] =] ¥, ) =2 == el
Drafts and Create Browse to E-mail File on T

Recent Pages  MNew Page Web Page Address My Computer Comy o Ecsatores i Tea

Texis Wesleyan Untversity

Link kext:

I Welcome Message Here

Web address [URL):
lhttp: £ twes. edudcetl/

@ Browse... ’ Use a web browser to find the page you want to link to.

Search your site for the file you want to link to.

4. Choose from one of the five different link types: Drafts, New Page, Web Page, Email address, or
File on My Computer.

5. Select or browse to the desired file.

6. Click OK when all fields have been completed.

After you insert a link, you can later change link text or change the page that the link opens.
To change link destination:
1. Inyour draft, select an existing link.
2. Do one of the following to open the Insert Link dialog box:
¢ On the Format menu select Link Properties.
e Right-click and select Link Properties.
3. Onthe Insert Link dialog box that appears select or browse to a new page.
4. Click OK.

After you insert a link, you can easily remove the link from your text or image.
To remove a link:
1. Inyour draft, select the link you want to remove.
2. Do one of the following:
e On the Format menu select Remove Link.
e Right-click and select Remove Link.
The link text or image in the draft is no longer a link.

For more information and additional guides and resources on Adobe Contribute and other
software check out http://www.txwes.edu/titleiii/

If you have any questions contact Meghan Foster at 817-531-6584 or mfoster@txwes.edu.
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